What are the minimum requirements to run ModMath?

ModMath runs on any iPad with iOS8 or later installed. This includes iPad 2 (second generation), iPad 3 (third generation), iPad 4 (fourth generation), iPad Air, iPad Mini, and iPad Mini 2.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk